宝塔bt面板phpmyadmin提示 您应升级到 MySQL 5.5.0 或更高版本

今天给一个客户处理问题,安装的phpmyadmin版本有点高,他的mysql因为有一些老的程序需要mysql5.1 ,宝塔默认的phpmyadmin报错:

 您应升级到 MySQL 5.5.0 或更高版本

其实是个很简单的问题,但是对于菜鸟技术来说,这好像很难。解决方法有两种

1.  安装mysql5.0对应的低版本的phpmyadmin

该方法很直接

2. 修改phpmyadmin的验证即可,phpmyadmin本身类似一个程序,没什么难度,修改地方:

查找phpmyadmin/libraries/common.inc.php
#查找
if (PMA_MYSQL_INT_VERSION < 50500) {
#更换为
if (PMA_MYSQL_INT_VERSION < 50100) {

-